About Me

Age:25 --- B.E.(Computer Science), Android/Java Developer, CCNA, CCNA SECURITY (IINS), CCNP (R&S), 4011 Recognized(NSA & CNSS)U.S.A. , MCSA, MCTS, REDHAT CERTIFIED NETWORK SECURITY ADMINISTRATOR(RH253), AFCEH.

Networks Practically

#############################################################
#############################################################



##  VLAN:


Vlan is a logical segmentation of the switched network.
Vlan = a Broadcast domain.
Vlan is implemented in order to divide the Broadcast domain,
and sometimes inorder to implement security measures.


I am demonstrating in Fig.1, that how a switch which has all its interfaces in the default Vlan 1 can communicate with each other, And in Fig.2, i will be demonstrating that as i assign the devices in different vlans, then they can no more access each other.


## CASE-1:

Here the two PCs are in same Vlans (Default Vlan 1), inorder to demonstrate that i gonna ping from both the PCs to each other. And they both will respond positively.

                         
   Fig. 1



## PC0:

PC>ping 192.168.0.20

Pinging 192.168.0.20 with 32 bytes of data:

Reply from 192.168.0.20: bytes=32 time=10ms TTL=128
Reply from 192.168.0.20: bytes=32 time=9ms TTL=128
Reply from 192.168.0.20: bytes=32 time=7ms TTL=128
Reply from 192.168.0.20: bytes=32 time=8ms TTL=128

Ping statistics for 192.168.0.20:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 7ms, Maximum = 10ms, Average = 8ms


## PC1:

PC>ping 192.168.0.10

Pinging 192.168.0.10 with 32 bytes of data:

Reply from 192.168.0.10: bytes=32 time=7ms TTL=128
Reply from 192.168.0.10: bytes=32 time=3ms TTL=128
Reply from 192.168.0.10: bytes=32 time=9ms TTL=128
Reply from 192.168.0.10: bytes=32 time=6ms TTL=128

Ping statistics for 192.168.0.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 3ms, Maximum = 9ms, Average = 6ms


##  CASE-2:

Now i have assigned both the PCs, PC0 and PC1 to Vlan 10 and Vlan 20 respectively. Now as both of them are in different Vlan, they won't be able to communicate with each other anymore.



    Fig. 2



##  Switch:


Switch#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#int range fa0/1 - 2
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#exit

Switch(config)#vtp domain hacker
Changing VTP domain name from NULL to hacker
Switch(config)#vtp password cisco
Setting device VLAN database password to cisco
Switch(config)#vtp mode server
Device mode already VTP SERVER.

Switch(config)#vlan 10
Switch(config-vlan)#name Maths
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name Science
Switch(config-vlan)#exit
Switch(config)#int fa0/1
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit

Switch(config)#int fa0/2
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit


##  PC0:

PC>ping 192.168.0.20

Pinging 192.168.0.20 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.0.20:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),


##  PC1:

PC>ping 192.168.0.10

Pinging 192.168.0.10 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.0.10:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),




## Last Words

The above is a small example to show how vlan can be effective in reducing the broadcast traffic. Vlan is also very effective in tightening the security by separating the security critical data on servers, by putting them in a vlan which is isolated from day to day user traffic and assigning this vlan's membership only to the authorized user.



#############################################################
#############################################################


## RIP v.1:




## Router-1:

VIVEK-ROUTER1(config)#int s2/0
VIVEK-ROUTER1(config-if)#ip address 192.168.0.1 255.255.255.252
VIVEK-ROUTER1(config-if)#no shutdown
VIVEK-ROUTER1(config-if)#clock rate 56000
VIVEK-ROUTER1(config-if)#bandwidth 64
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

VIVEK-ROUTER1(config)#int fa0/0
VIVEK-ROUTER1(config-if)#ip address 192.168.0.5 255.255.255.252
VIVEK-ROUTER1(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up




## Router-2:

VIVEK-ROUTER2(config)#int s2/0
VIVEK-ROUTER2(config-if)#ip address 192.168.0.2 255.255.255.252
VIVEK-ROUTER2(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

VIVEK-ROUTER2(config)#int fa0/0
VIVEK-ROUTER2(config-if)#ip address 192.168.0.9 255.255.255.252
VIVEK-ROUTER2(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up



## PC-1:

IP Address......................: 192.168.0.6
Subnet Mask.....................: 255.255.255.252
Default Gateway.................: 192.168.0.5


## PC-2:

IP Address......................: 192.168.0.10
Subnet Mask.....................: 255.255.255.252
Default Gateway.................: 192.168.0.9



## Ping from PC1-PC2:

PC>ping 192.168.0.10

Pinging 192.168.0.10 with 32 bytes of data:

Reply from 192.168.0.10: bytes=32 time=13ms TTL=126
Reply from 192.168.0.10: bytes=32 time=7ms TTL=126
Reply from 192.168.0.10: bytes=32 time=10ms TTL=126
Reply from 192.168.0.10: bytes=32 time=7ms TTL=126

Ping statistics for 192.168.0.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 7ms, Maximum = 13ms, Average = 9ms


#############################################################
#############################################################